Packet Tracer 7.1.1 tutorial - BGP configuration
BGP in Packet Tracer
BGP (Border Gateway Protocol) is the core routing protocol of the Internet. It is described as a path vector protocol as BGP does not use traditional IGP (OSPF, EIGRP, RIP) metrics, but makes routing decisions based on path, network policies and/or rulesets. It maintains a table of IP networks or 'prefixes' which designate network reachability among autonomous systems (AS).
BGP protocol support has been added in Packet Tracer in the 5.3 version. This allows Cisco CCNP Route students to better understand this complex routing protocol and to be prepared for the simulation questions in the exam.
Internal BGP (iBGP) is currently not supported in Packet Tracer (see screenshot below). iBGP support has still not been added in the new Packet Tracer 7.1.1 version
IOS commands available in Packet Tracer 7.1.1
enable mode
- show ip bgpexit
- show ip bgp neighbors
- show ip bgp summary
- clear ip bgp *
router bgp mode
- bgp log-neighbor-changes
- bgp redistribute-internal
- bgp router-id A.B.C.D
- exit
- neighbor A.B.C.D next-hop-self
- neighbor A.B.C.D remote-as <1-65535>
- network A.B.C.D
- network A.B.C.D mask A.B.C.D
- redistribute connected / eigrp <1-65535> / ospf <1-65535> / static
- synchronization
- timers bgp <0-65535> <0-65535>
Sample BGP network
WAN1 router configuration :
A simple eBGP peering with ISP1 router is configured in the WAN1 router.
interface Serial0/0/0
ip address 156.12.1.6 255.255.255.252
!
router bgp 65000
bgp log-neighbor-changes
no synchronization
neighbor 156.12.1.5 remote-as 10000
ISP1 router configuration :
Several loopback interfaces are configured in ISP1 router to simulate connected networks whose are advertised to WAN1 router through the BGP peering.
interface Loopback0
ip address 156.100.1.1 255.255.255.0
!
interface Loopback1
ip address 156.100.2.1 255.255.255.0
!
interface Loopback2
ip address 156.100.4.1 255.255.254.0
!
interface Serial0/0/0
ip address 156.12.1.5 255.255.255.252
clock rate 500000
!
router bgp 10000
bgp log-neighbor-changes
no synchronization
neighbor 156.12.1.6 remote-as 65000
network 156.100.4.0 mask 255.255.254.0
network 156.100.2.0 mask 255.255.255.0
network 156.100.1.0 mask 255.255.255.0
!